Site hacked

Announcements that go here will appear on the front page.

Moderators: Bob the Hamster, marionline, SDHawk

User avatar
jcenterprises
Slime Knight
Posts: 132
Joined: Sun Aug 21, 2011 7:30 pm
Contact:

Post by jcenterprises »

Haven't contacted him yet, wasn't sure if this was superwalrusland or Slime Salad causing the problem, and was hoping he'd see this, guess I'll PM him now.
User avatar
The Wobbler
A Scrambled Egg
Posts: 2615
Joined: Mon Oct 15, 2007 8:36 pm
Location: Underwater
Contact:

Post by The Wobbler »

I don't know anything about computers, someone else fix it. I'm also not personally seeing anything weird here.

Ok, I can see that there's a redirect to viajespirineoainsa now, but it doesn't seem to do anything. I can't figure out where it is in my wiki code but I don't know nearly enough to even know where to begin looking.

Have I mentioned that I don't like computers at all??
Last edited by The Wobbler on Wed Sep 17, 2014 3:37 am, edited 3 times in total.
User avatar
Bob the Hamster
Liquid Metal King Slime
Posts: 7460
Joined: Tue Oct 16, 2007 2:34 pm
Location: Hamster Republic (Ontario Enclave)
Contact:

Post by Bob the Hamster »

As far as I can tell, your wiki is still running Mediawiki version 1.15, which was the current version in the beginning of 2010.

So the first thing to do is to upgrade it to the latest version. That might even fix the whole problem right there.

Who is your web host?

Some web hosts might have an option to keep mediawiki automatically updated. I do have something like that set up for the ohrrpgce wiki, so if you need any further help setting it up to update itself, let me know.
User avatar
The Wobbler
A Scrambled Egg
Posts: 2615
Joined: Mon Oct 15, 2007 8:36 pm
Location: Underwater
Contact:

Post by The Wobbler »

Host gator. I tried updating and it told me I couldn't because my php version was too old but I can clearly see that it's not.
User avatar
Bob the Hamster
Liquid Metal King Slime
Posts: 7460
Joined: Tue Oct 16, 2007 2:34 pm
Location: Hamster Republic (Ontario Enclave)
Contact:

Post by Bob the Hamster »

Ah, interesting. This might be a job for Host Gator's tech support.

I googled around and found that they seem to have a good reputation for medaiwiki hosting, and seem to have support for automatic updating, but it might not have been available back when you first set up your wiki.

They might be able to help you fix it faster than I could.
User avatar
The Wobbler
A Scrambled Egg
Posts: 2615
Joined: Mon Oct 15, 2007 8:36 pm
Location: Underwater
Contact:

Post by The Wobbler »

Yeah, they've got a service called Quickinstall that works well, but it didn't exist when I set up the site a couple years ago, so it can't even detect my current install.

I got some pointers from JSH and Shadowiii of where my scripts need to be fixed so I'm working on that now.

Edit: As far as I can tell it's fixed now and we're disease free. Thanks for calling this to my attention. The wiki is going to be taken down and replaced at some point since it's not allowing me to update it, but for now at least this is taken care of. Let me know if you see anything else weird.
Last edited by The Wobbler on Thu Sep 18, 2014 2:37 am, edited 1 time in total.
User avatar
Bob the Hamster
Liquid Metal King Slime
Posts: 7460
Joined: Tue Oct 16, 2007 2:34 pm
Location: Hamster Republic (Ontario Enclave)
Contact:

Post by Bob the Hamster »

It is probably possible to do a backup of the database, reinstall the wiki using the Quickinstall, and then restore the database. I even found a place that seemed to be saying that Host Gator would do that for you if you were moving to them from another host
User avatar
The Wobbler
A Scrambled Egg
Posts: 2615
Joined: Mon Oct 15, 2007 8:36 pm
Location: Underwater
Contact:

Post by The Wobbler »

Tried that earlier. Got this message, and then nothing would work: "MediaWiki 1.22 requires at least PHP version 5.3.2, you are using PHP 5.2.17."

According to my host, I'm actually using PHP 5.4.32.
Post Reply