Post new topic    
Page 1, 2  »
Metal Slime
Send private message
Mac OHR game running at half speed 
 PostFri May 29, 2020 5:53 pm
Send private message Reply with quote
I found a weird issue. I have a 32 bit Mac version of Alien Squatter. When I play it on my Mac, the game runs at half speed. The music plays at normal speed, but the animations and player walk speeds are slow. I have the game set to run at 60 FPS. I wonder if that has anything to do with it?

I can't test the 64 bit version because my Mac won't run it. If it matters, I'm on Sierra (10.12.6).

Any idea what the issue might be?

Oh yeah, I'm currently using fulfluns stable. I haven't done gorgonzola yet.
Metal King Slime
Send private message
 
 PostSat May 30, 2020 1:08 am
Send private message Reply with quote
This is a known bug in our frame rate control, and causes random framerate drops which get larger the closer the game is set to 60fps, but has the biggest effect on Macs where it halves the framerate when set to 60fps.
It's been around a long time. Sorry I haven't gotten around to fixing it, I know it's very serious. I believe it affects all operating systems where the window manager does compositing with vsync (so is affected by graphics driver settings - I've only seen it on Linux when using the nVidia propriety driver and jumping through hoops to get vsync working properly). I see I haven't filed this one on github yet...

Setting to framerate to somethign like 50 or 45 might be a workaround for now. I would also suggest trying the SDL2 build instead... but that currently doesn't run at all on Mac.

Why can't you run the 64-bit Mac package? That's concerning. If you have OS 10.12, the Mac is not ancient and can run 64-bit apps. What happens when you try? Could you also try running the program from Terminal to get an error message, if you don't get one when clicking on the .app? Run "path/to/OHRRPGCE-Game.app/Contents/MacOS/ohrrpgce-game".
Metal Slime
Send private message
 
 PostSat May 30, 2020 5:44 am
Send private message Reply with quote
TMC wrote:
This is a known bug in our frame rate control, and causes random framerate drops which get larger the closer the game is set to 60fps, but has the biggest effect on Macs where it halves the framerate when set to 60fps.
It's been around a long time. Sorry I haven't gotten around to fixing it, I know it's very serious. I believe it affects all operating systems where the window manager does compositing with vsync (so is affected by graphics driver settings - I've only seen it on Linux when using the nVidia propriety driver and jumping through hoops to get vsync working properly). I see I haven't filed this one on github yet...

Setting to framerate to somethign like 50 or 45 might be a workaround for now. I would also suggest trying the SDL2 build instead... but that currently doesn't run at all on Mac.

Why can't you run the 64-bit Mac package? That's concerning. If you have OS 10.12, the Mac is not ancient and can run 64-bit apps. What happens when you try? Could you also try running the program from Terminal to get an error message, if you don't get one when clicking on the .app? Run "path/to/OHRRPGCE-Game.app/Contents/MacOS/ohrrpgce-game".


Good to know that you're aware of it the issue. =) Weird that I haven't noticed this bug on Windows builds of the game. You said it's most drastic on Mac, but I haven't noticed any unexpected framerate behavior in Windows.

You mentioned using the SDL2 build. What does that mean?

When I try to run the 64 bit Mac version of Alien Squatter, the screen is black. I can hear the music, but I can't see anything. I know at least one other person has had the same issue. It's 1AM now, but tomorrow, I'll run it in terminal and show you what happens.
Metal King Slime
Send private message
 
 PostSat May 30, 2020 12:46 pm
Send private message Reply with quote
To notice the problem on Windows, try watching the framerate counter. Press ctrl-` (tilde key) once or twice to see the draw/display framerate. Draw FPS means the tick rate at which the engine logic runs, Display FPS is how many of those frames actually get sent to the OS for display, which can be less than Draw FPS due to frame skipping. Also, if you hold Shift-Tab you're meant to see Draw FPS multiply 6x (unless it's capped because you hit 100% CPU usage) and Display FPS cap out at something (either 60 or 90 FPS depending on vsync). This bug prevents that happening on some computers.

Don't bother running it from Terminal; I thought the problem was that it doesn't run at all, in which case a more helpful error message might be printed.

Quote:
When I try to run the 64 bit Mac version of Alien Squatter, the screen is black.

Wow. If you download Gorgonzola 64 bit for Mac, do Custom and Game both do that? There are some relevant changes in Gorgonzola.

And from which OS did you package the Mac version of Alien Squatter? And with which version? Note: when you package a game for a different OS it downloads either the latest nightly build of the engine (if Custom is a nightly build), or the latest stable release (otherwise), NOT the stable release or nightly matching the version of Custom you're running. So if you packaged it after May 2th you got Gorgonzola.

There is a 64-bit gfx_sdl2 (SDL 2.0) Mac build for download from the nightly builds directory (OHRRPGCE-wip-x86_64-sdl2.dmg), but don't bother trying it, I already know it doesn't work.
SDL2 (gfx_sdl2) is the future; in fact I want to make gfx_sdl2 the default on all OSes except Android in the next release. If it's working by then.
Metal Slime
Send private message
 
 PostSat May 30, 2020 4:02 pm
Send private message Reply with quote
TMC wrote:
Quote:
When I try to run the 64 bit Mac version of Alien Squatter, the screen is black.

Wow. If you download Gorgonzola 64 bit for Mac, do Custom and Game both do that? There are some relevant changes in Gorgonzola.

And from which OS did you package the Mac version of Alien Squatter? And with which version? Note: when you package a game for a different OS it downloads either the latest nightly build of the engine (if Custom is a nightly build), or the latest stable release (otherwise), NOT the stable release or nightly matching the version of Custom you're running. So if you packaged it after May 2th you got Gorgonzola.


I did some experimenting.

I just downloaded Gorgonzola 64 bit for Mac. Custom and Game run fine.
When I test Alien Squatter from within custom, there is no problem.
When I try to open the .rpg file from Game, the screen is black and I hear the sound.
When I package a 64-bit Mac bundle using the distribute menu in custom, I have the same problem.

Here is gdebugarchive:

Code:
  +++|=========>  APPLY SWORD, CUT HERE (Please send whole sections)
 0.2   ----Starting OHRRPGCE Game----
 0.2  05-30-2020 10:42:52
 0.2  OHRRPGCE gorgonzola 20200502.11799 gfx_sdl/music_sdl FreeBASIC 1.06.0 (04-29-2016) GCC 4.7.4 x86_64  Built on loyalist.local -gen gcc Mac OS X/Darwin 64-bit
 0.2  exepath: /Users/AHagen/Desktop/asquatter-mac/asquatter.app/Contents/MacOS, exe: /Users/AHagen/Desktop/asquatter-mac/asquatter.app/Contents/MacOS/ohrrpgce-game
 0.2  orig_dir: /Users/AHagen/Desktop/asquatter-mac
 0.2  curdir: /Users/AHagen/Desktop/asquatter-mac
 0.2  Runtime info:   music_sdl, SDL 1.2.14, SDL_Mixer 1.2.11  Mac OS 10.12.6
 0.2  ! ERROR: Data directory data/defaultgfx not found. The OHRRPGCE apparently isn't installed properly. Try reinstalling.
 0.2  ! showerror: no display
 0.2  ! (BUG) OPENFILE: empty filename
 0.2  Initialising gfx_sdl...
 0.2  recenter_window_hint()
 0.5  SDL: screen size 1680x1050
 0.5  setvideomode zoom=2 w*h = 640*400
 0.5  gfx_sdl: created screensurface size=640*400 depth=32 flags=4 R=ff00 G=ff0000 B=ff000000 A=0 is_RGBcolor=0
 0.5  gfx_sdl "SDL 1.2.14 (0 joysticks) Driver:Quartz"
 0.5  disable_native_text_input=0
 0.5  music_sdl, SDL_Mixer 1.2.11 (22050Hz)
 0.6  Setting default window settings...
 0.6  setvideomode zoom=2 w*h = 640*400
 0.6  gfx_sdl: created screensurface size=640*400 depth=32 flags=4 R=ff00 G=ff0000 B=ff000000 A=0 is_RGBcolor=0
 0.6  setvideomode zoom=2 w*h = 640*400
 0.6  gfx_sdl: created screensurface size=640*400 depth=32 flags=4 R=ff00 G=ff0000 B=ff000000 A=0 is_RGBcolor=0
 0.6  set_resolution 320*200
 0.6  Setting graphics scaling to x2 change_windowsize=-1

  +++|=========>  APPLY SWORD, CUT HERE (Please send whole sections)

 0.2   ----Starting OHRRPGCE Game----
 0.2  05-30-2020 10:43:25
 0.2  OHRRPGCE gorgonzola 20200502.11799 gfx_sdl/music_sdl FreeBASIC 1.06.0 (04-29-2016) GCC 4.7.4 x86_64  Built on loyalist.local -gen gcc Mac OS X/Darwin 64-bit
 0.2  exepath: /Users/AHagen/Desktop/asquatter-mac/asquatter.app/Contents/MacOS, exe: /Users/AHagen/Desktop/asquatter-mac/asquatter.app/Contents/MacOS/ohrrpgce-game
 0.2  orig_dir: /Users/AHagen/Desktop/asquatter-mac
 0.2  curdir: /Users/AHagen/Desktop/asquatter-mac
 0.2  Runtime info:   music_sdl, SDL 1.2.14, SDL_Mixer 1.2.11  Mac OS 10.12.6
 0.2  ! ERROR: Data directory data/defaultgfx not found. The OHRRPGCE apparently isn't installed properly. Try reinstalling.
 0.2  ! showerror: no display
 0.2  ! (BUG) OPENFILE: empty filename
 0.2  Initialising gfx_sdl...
 0.2  recenter_window_hint()
 0.4  SDL: screen size 1680x1050
 0.4  setvideomode zoom=2 w*h = 640*400
 0.5  gfx_sdl: created screensurface size=640*400 depth=32 flags=4 R=ff00 G=ff0000 B=ff000000 A=0 is_RGBcolor=0
 0.5  gfx_sdl "SDL 1.2.14 (0 joysticks) Driver:Quartz"
 0.5  disable_native_text_input=0
 0.5  music_sdl, SDL_Mixer 1.2.11 (22050Hz)
 0.5  Setting default window settings...
 0.5  setvideomode zoom=2 w*h = 640*400
 0.5  gfx_sdl: created screensurface size=640*400 depth=32 flags=4 R=ff00 G=ff0000 B=ff000000 A=0 is_RGBcolor=0
 0.5  setvideomode zoom=2 w*h = 640*400
 0.5  gfx_sdl: created screensurface size=640*400 depth=32 flags=4 R=ff00 G=ff0000 B=ff000000 A=0 is_RGBcolor=0
 0.5  set_resolution 320*200
 0.5  Setting graphics scaling to x2 change_windowsize=-1


Here is gdebug

Code:
 0.2   ----Starting OHRRPGCE Game----
 0.2  05-30-2020 10:50:55
 0.2  OHRRPGCE gorgonzola 20200502.11799 gfx_sdl/music_sdl FreeBASIC 1.06.0 (04-29-2016) GCC 4.7.4 x86_64  Built on loyalist.local -gen gcc Mac OS X/Darwin 64-bit
 0.2  exepath: /Users/AHagen/Desktop/asquatter-mac/asquatter.app/Contents/MacOS, exe: /Users/AHagen/Desktop/asquatter-mac/asquatter.app/Contents/MacOS/ohrrpgce-game
 0.2  orig_dir: /Users/AHagen/Desktop/asquatter-mac
 0.2  curdir: /Users/AHagen/Desktop/asquatter-mac
 0.2  Runtime info:   music_sdl, SDL 1.2.14, SDL_Mixer 1.2.11  Mac OS 10.12.6
 0.2  ! ERROR: Data directory data/defaultgfx not found. The OHRRPGCE apparently isn't installed properly. Try reinstalling.
 0.2  ! showerror: no display
 0.2  ! (BUG) OPENFILE: empty filename
 0.2  Initialising gfx_sdl...
 0.2  recenter_window_hint()
 0.4  SDL: screen size 1680x1050
 0.5  setvideomode zoom=2 w*h = 640*400
 0.5  gfx_sdl: created screensurface size=640*400 depth=32 flags=4 R=ff00 G=ff0000 B=ff000000 A=0 is_RGBcolor=0
 0.5  gfx_sdl "SDL 1.2.14 (0 joysticks) Driver:Quartz"
 0.5  disable_native_text_input=0
 0.5  music_sdl, SDL_Mixer 1.2.11 (22050Hz)
 0.5  Setting default window settings...
 0.5  setvideomode zoom=2 w*h = 640*400
 0.5  gfx_sdl: created screensurface size=640*400 depth=32 flags=4 R=ff00 G=ff0000 B=ff000000 A=0 is_RGBcolor=0
 0.5  setvideomode zoom=2 w*h = 640*400
 0.5  gfx_sdl: created screensurface size=640*400 depth=32 flags=4 R=ff00 G=ff0000 B=ff000000 A=0 is_RGBcolor=0
 0.5  set_resolution 320*200
 0.5  Setting graphics scaling to x2 change_windowsize=-1
Metal Slime
Send private message
 
 PostSat May 30, 2020 4:11 pm
Send private message Reply with quote
Screen Shot 2020-05-30 at 11.06.17 AM.png
 

Download
 Filesize:  845.58 KB
 Downloaded:  8 times
Some more info...

I set the game so it didn't start in full screen and tried running it from Game again.

I got the attached error message right before the game loaded, but then it loaded fine and I could see the visuals.

Here is the gdebug info from that...

Code:
 0.3   ----Starting OHRRPGCE Game----
 0.3  05-30-2020 11:05:57
 0.3  OHRRPGCE gorgonzola 20200502.11799 gfx_sdl/music_sdl FreeBASIC 1.06.0 (04-29-2016) GCC 4.7.4 x86_64  Built on loyalist.local -gen gcc Mac OS X/Darwin 64-bit
 0.3  exepath: /private/var/folders/s1/g0fvrhxd1w3578b623fpmd200000gp/T/AppTranslocation/C2DFF1E9-67B0-4B70-89A3-175D7064EB2E/d/OHRRPGCE-Game.app/Contents/MacOS, exe: /private/var/folders/s1/g0fvrhxd1w3578b623fpmd200000gp/T/AppTranslocation/C2DFF1E9-67B0-4B70-89A3-175D7064EB2E/d/OHRRPGCE-Game.app/Contents/MacOS/ohrrpgce-game
 0.3  orig_dir: /private/var/folders/s1/g0fvrhxd1w3578b623fpmd200000gp/T/AppTranslocation/C2DFF1E9-67B0-4B70-89A3-175D7064EB2E/d
 0.3  curdir: /private/var/folders/s1/g0fvrhxd1w3578b623fpmd200000gp/T/AppTranslocation/C2DFF1E9-67B0-4B70-89A3-175D7064EB2E/d
 0.3  Runtime info:   music_sdl, SDL 1.2.14, SDL_Mixer 1.2.11  Mac OS 10.12.6
 0.3  ! ERROR: Data directory data/defaultgfx not found. The OHRRPGCE apparently isn't installed properly. Try reinstalling.
 0.3  ! showerror: no display
 0.3  ! (BUG) OPENFILE: empty filename
 0.3  Initialising gfx_sdl...
 0.3  recenter_window_hint()
 0.6  SDL: screen size 1680x1050
 0.6  setvideomode zoom=2 w*h = 640*400
 0.6  gfx_sdl: created screensurface size=640*400 depth=32 flags=4 R=ff00 G=ff0000 B=ff000000 A=0 is_RGBcolor=0
 0.6  gfx_sdl "SDL 1.2.14 (0 joysticks) Driver:Quartz"
 0.6  disable_native_text_input=0
 0.7  music_sdl, SDL_Mixer 1.2.11 (22050Hz)
 0.7  Setting default window settings...
 0.7  setvideomode zoom=2 w*h = 640*400
 0.7  gfx_sdl: created screensurface size=640*400 depth=32 flags=4 R=ff00 G=ff0000 B=ff000000 A=0 is_RGBcolor=0
 0.7  setvideomode zoom=2 w*h = 640*400
 0.7  gfx_sdl: created screensurface size=640*400 depth=32 flags=4 R=ff00 G=ff0000 B=ff000000 A=0 is_RGBcolor=0
 0.7  set_resolution 320*200
 0.7  Setting graphics scaling to x2 change_windowsize=-1
 0.7  general.reld not present, creating

19.8   ----Loading /Users/AHagen/Desktop/ohrrpgce/asquatter.rpg----
19.8  curdir: /Users/AHagen/Desktop/ohrrpgce
19.8  tmpdir: /Users/AHagen/Library/Caches/OHRRPGCE/ohrrpgce20200530110557.102.tmp/
19.8  settings_dir: /Users/AHagen/Library/Application Support/OHRRPGCE
19.8  savedir: /Users/AHagen/Desktop/ohrrpgce/asquatter.saves
19.9  Name: Alien Squatter v1.05
19.9  Partial game data upgrade...
19.9  Last edited by: [[OHRRPGCE gorgonzola 20200502.11799 gfx_sdl/music_sdl FreeBASIC 1.06.0 (04-29-2016) GCC 4.7.4 x86_64  Built on loyalist.local  -gen gcc Mac OS X/Darwin 64-bit]] branch_rev 11797
19.9  archinym creation info: OHRRPGCE etheldreme 20171203
20.0  plotscr.hsd version: 3U
20.5  lock_resolution()
20.5  setvideomode zoom=2 w*h = 640*400
20.5  gfx_sdl: created screensurface size=640*400 depth=32 flags=4 R=ff00 G=ff0000 B=ff000000 A=0 is_RGBcolor=0
20.5  Desktop resolution: 1680*1050
20.5  automatic_scale_factor(0.5), screen size: 1680*1050
20.5  Setting graphics scaling to x3 change_windowsize=-1
20.5  set_zoom change_windowsize=-1, zoom=3 old size = 640,400
20.5  recenter_window_hint()
20.5  setvideomode zoom=3 w*h = 960*600
20.5  gfx_sdl: created screensurface size=960*600 depth=32 flags=4 R=ff00 G=ff0000 B=ff000000 A=0 is_RGBcolor=0
20.5  /Users/AHagen/Library/Application Support/OHRRPGCE/asquatter/gameconfig.ini : gfx.fullscreen = -1, genFullscreen = 0
20.5  setvideomode zoom=3 w*h = 960*600
20.9  ! Failed to open display (windowed = 0): Failed to find display resolution: 1024x640x32
20.9  setwindowed: fallback to previous zoom
20.9  setvideomode zoom=3 w*h = 960*600
20.9  gfx_sdl: created screensurface size=960*600 depth=32 flags=4 R=ff00 G=ff0000 B=ff000000 A=0 is_RGBcolor=0
27.1  genRungameFullscreenIndependent: 0
27.1  setvideomode zoom=3 w*h = 960*600
27.1  gfx_sdl: created screensurface size=960*600 depth=32 flags=4 R=ff00 G=ff0000 B=ff000000 A=0 is_RGBcolor=0
29.7  Cleaning up and terminating 0
29.7  Closing music backend...
29.7  ...done
29.7  Deleting tmpdir /Users/AHagen/Library/Caches/OHRRPGCE/ohrrpgce20200530110557.102.tmp/
29.8  Closing gfx backend & allmodex...
29.8  ...done
29.8  End.


I wonder what line 0.3 means.
Metal King Slime
Send private message
 
 PostSun May 31, 2020 10:57 am
Send private message Reply with quote
Thanks for all the testing. There seem to be multiple bugs here, like the "Data directory data/defaultgfx not found" message. And it's hard for me to make sense of everything in these logs. I don't know what causes "Failed to find display resolution: 1024x640x32". In a week's time I should have access to a Mac, and then I can tackle them.

I didn't realise you were talking about fullscreen mode. That helps to explain the problem.

Quote:
I set the game so it didn't start in full screen and tried running it from Game again.

The fullscreen setting in Custom is just a default setting, which is ignored once you've actually played the game and customised the fullscreen setting (including via menu bar, Cmd-F, Alt-Enter, or Windowed/Fullscreen in the menu). That's what the line
/Users/AHagen/Library/Application Support/OHRRPGCE/asquatter/gameconfig.ini : gfx.fullscreen = -1, genFullscreen = 0
tells: genFullscreen, the default setting in Custom is off, but the .ini is set to fullscreen.
But the first three logs you posted don't seem to have tried to fullscreen. Or maybe I need to improve the logging.
Metal Slime
Send private message
 
 PostMon Jun 01, 2020 5:58 pm
Send private message Reply with quote
TMC wrote:
Thanks for all the testing. There seem to be multiple bugs here, like the "Data directory data/defaultgfx not found" message. And it's hard for me to make sense of everything in these logs. I don't know what causes "Failed to find display resolution: 1024x640x32". In a week's time I should have access to a Mac, and then I can tackle them.

I didn't realise you were talking about fullscreen mode. That helps to explain the problem.

Quote:
I set the game so it didn't start in full screen and tried running it from Game again.

The fullscreen setting in Custom is just a default setting, which is ignored once you've actually played the game and customised the fullscreen setting (including via menu bar, Cmd-F, Alt-Enter, or Windowed/Fullscreen in the menu). That's what the line
/Users/AHagen/Library/Application Support/OHRRPGCE/asquatter/gameconfig.ini : gfx.fullscreen = -1, genFullscreen = 0
tells: genFullscreen, the default setting in Custom is off, but the .ini is set to fullscreen.
But the first three logs you posted don't seem to have tried to fullscreen. Or maybe I need to improve the logging.


Well, I can help with more testing if you want. Let me know what else you would like me to try. =)
Metal Slime
Send private message
 
 PostWed Jul 08, 2020 2:23 am
Send private message Reply with quote
I've got a new game release coming up. I'm probably going to hold off on a Mac version considering this bug. Out of curiosity, is the half speed at 60fps Mac OS bug likely to get fixed? If not, I might consider creating a 30fps version just for Mac.

Thanks TMC. You rock!
Liquid Metal King Slime
Send private message
 
 PostWed Jul 08, 2020 8:20 pm
Send private message Reply with quote
I am wondering if the same bug that affects Mac might also affect Android. I noticed some odd speed fluctuations when I was playing recently. Not all the time, but sometimes
Metal King Slime
Send private message
 
 PostThu Jul 09, 2020 9:37 am
Send private message Reply with quote
Oops, yes, I did forget about this bug, because I only just got the ability to test on a Mac again, but only for a couple more days. So I'm going to work on it now.

James: If you saw those speed fluctuations in a game with a high-to-moderate framerate then it probably is the same bug, since it's not Mac-specific.
Liquid Metal King Slime
Send private message
 
 PostThu Jul 09, 2020 10:31 am
Send private message Reply with quote
Yes, I saw it on Alien Squatter running at 60fps on Android
Metal King Slime
Send private message
 
 PostWed Jul 15, 2020 10:40 am
Send private message Reply with quote
It was tricky, but I think I've solved this bug (the fix will be in tomorrow's nightlies), although I can't test it on Mac myself. Instead, I emulated how vsync works on Macs to reproduce and fix it. The bug was in Mac-specific code, so I don't think could explain similar problems on other OSes, though there's the possibility. I actually wasn't able to reproduce the problem on Linux anymore. Haven't tried Windows or android yet.
We really need a way to access the debug menu on Android. I wonder what the draw and display FPS were during those speed fluctuations.

I also totally forgot you had reported other problem in this thread.
I spent my time working on other Mac bugs instead.
Metal Slime
Send private message
 
 PostWed Jul 15, 2020 11:33 pm
Send private message Reply with quote
TMC wrote:
It was tricky, but I think I've solved this bug (the fix will be in tomorrow's nightlies), although I can't test it on Mac myself. Instead, I emulated how vsync works on Macs to reproduce and fix it. The bug was in Mac-specific code, so I don't think could explain similar problems on other OSes, though there's the possibility. I actually wasn't able to reproduce the problem on Linux anymore. Haven't tried Windows or android yet.
We really need a way to access the debug menu on Android. I wonder what the draw and display FPS were during those speed fluctuations.

I also totally forgot you had reported other problem in this thread.
I spent my time working on other Mac bugs instead.


I'll test when the the nightly is uploaded. I have a Mac to try.
Metal Slime
Send private message
 
 PostSat Jul 18, 2020 4:20 pm
Send private message Reply with quote
TMC wrote:
It was tricky, but I think I've solved this bug (the fix will be in tomorrow's nightlies), although I can't test it on Mac myself. Instead, I emulated how vsync works on Macs to reproduce and fix it. The bug was in Mac-specific code, so I don't think could explain similar problems on other OSes, though there's the possibility. I actually wasn't able to reproduce the problem on Linux anymore. Haven't tried Windows or android yet.
We really need a way to access the debug menu on Android. I wonder what the draw and display FPS were during those speed fluctuations.

I also totally forgot you had reported other problem in this thread.
I spent my time working on other Mac bugs instead.


Seems to work okay. The framerate is between 57-59 consistently.

As I'm sure you guessed, the bug where the screen is black in full screen mode still persists. Let me know if you need more info from me about that.

Thanks! Eventually this Mac thing will get ironed out. =D
Display posts from previous:
Page 1, 2  »